PHP5.3でcakePHPを使ったときの警告

PCに入れていたxamppが壊れたので最新版を取得して入れなおし。PHP5.3になったことで各システムから非推奨の記述に対して警告が多発。

WordPressは最新版にしたことでエラーが消えた。cakePHPもそうかもしれないが、面倒なので警告が出ないように処理。

cake/lib/configure.php

if (isset($config[‘debug’])) {
if ($_this->debug) {
error_reporting(E_ALL);
error_reporting(E_ALL ^ E_DEPRECATED ^ E_NOTICE);//ここを追記

cake/lib/debugger.php

/*ここをコメントアウト
case E_NOTICE:
case E_USER_NOTICE:
$error = ‘Notice’;
$level = LOG_NOTICE;
break;*/

You can follow any responses to this entry through the RSS 2.0 feed. You can leave a response, or trackback from your own site.

コメントを残す

XHTML: You can use these tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>